Posts Tagged 'mikrotik'

Squid Proxy + Mikrotik

I have installed a cache proxy to centos server and works with good TCP_HIT. i’m using centos 5.x. proxy took the data that we request from browsing activities and save it as cache. the second request will take from this cache, that means the connection uses full bandwith on the local network. we got two thing, reduce bandwith consumtion from the ISP and increase the speed. squid has other feature such as redirect, blocking, etc.

on this case, the proxy’s IP set to 192.168.168.12, the same level to client computers.

install squid package from repository.

yum -y install

edit /etc/squid/squid.conf

change/add some.

#change the proxy port to 3128 and set as transparent. The transparent parameter means, this proxy can be used over the IP with port redirect.
 http_port 3128 transparent
 #add the hostname
 visible_hostname proxyserver
 #the TCP_HIT quantities depends on the refresh pattern parameter.
 refresh_pattern ^ftp:        1440    20%    10080
 refresh_pattern ^gopher:        1440    0%    1440
 refresh_pattern ^http:        720    90%    432000
 refresh_pattern -i (/cgi-bin/|\?) 0    0%    0
 refresh_pattern (Release|Package(.gz)*)$    0    20%    2880
 refresh_pattern -i \.(gif|png|jpg|jpeg|ico)$ 10080 90% 43200 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(iso|avi|wav|mp3|mp4|mpeg|mpg|swf|flv|x-flv)$ 43200 90% 432000 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(deb|rpm|exe|ram|bin|pdf|ppt|doc|tiff)$ 10080 90% 43200 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(zip|gz|arj|lha|lzh|tar|tgz|cab|rar)$ 10080 95% 43200 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(html|htm|css|js|php|asp|aspx|cgi) 1440 40% 40320
 refresh_pattern .        0    20%    4320

save the file. then, create a swap directory

/usr/sbin/squid -z #swap

Check squid configuration. If there is an output, something wrong with squid.config, otherwise, all’s ok.

/usr/sbin/squid -k parse

start squid service

/etc/rc.d/init.d/squid start

use chkconfig to set squid to load on boot.

/sbin/chkconfig squid on

now, configure browser’s proxy to IP port 3128. open some static webpages and check log file.

tail /var/log/squid/access.log

if success, the webpage will loaded and squid will generate TCP_MISS to the logfile. we need to check again. give attention to logfile. clear the browser cache or use other computer to load the same pages. if TCP_HIT appears on the log, then your squid server is working fine. TCP_MISS means the data is not exist on cache and proxy server will load it from the internet. You will get TCP_HIT when data is exists and client load it from cache. the more you get TCP_IP, the more browsing speed increased for lots of data.

this is not yet complete. we need to enable the proxy server on router and setup it to redirect to 192.168.168.12:3128 using parent-proxy parameter.

set enabled=yes src-address=0.0.0.0 port=3328 parent-proxy=192.168.168.12 parent-proxy-port=3128

then, add a nat rule to force all request to router’s proxy (port 3328). strike the command bellow.

chain=dstnat action=redirect to-ports=3328 protocol=tcp src-address=!192.168.168.12 dst-port=80

voila. :)

NB : ini tulisan pertama dengan bahasa inggris. saya harap banyak yang salah dan seseorang memberitahu sehingga saya bisa belajar dari itu.

Dasar Mikrotik Plus Manajemen Bandwith

ditulis sebagai catatan pengingat. asumsi, menggunakan modem speedy (192.168.1.1) dan jaringan lokal 192.168.10.xx. salah satu client yang diatur bandwithnya adalah 192.168.10.2

1. Menambahkan password

$/password
 old password:
 new password:*****
 retype password:******

2. Memberi nama pada interface

/interface set 0 name=speedy
 /interface set 1 name=local

3. Memberi nama hostname

/system identity set name=routermikrotik

4. Set IP Address

/ip address add interface=speedy address 192.168.1.2 netmask 255.255.255.0
 /ip address add interface=local address 192.168.10.1 netmask 255.255.255.0

5.Set Gateway

/ip route add gateway=192.168.1.1

6. Set NAT

/ip firewall nat add chain=srcnat action=masquerade out-interface=speedy

7. DNS server

/ip dns set primary-dns=8.8.8.8 allow-remoterequests=yes

8. Manajemen Bandwith

/ip firewall mangle add chain=prerouting src-address=192.168.10.2 dst-address=0.0.0.0/0 action=mark-connection new-connection-mark=client01-con passthrough=yes
 /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=client01 passthrough=yes connection-mark=client01-con
 /queue tree add name=client01-up parent=speedy packet-mark=client01 limit-at=64k max-limit=512k
 /queue tree add name=client01-down parent=local packet-mark=client01 limit-at=64k max-limit=512k

4 perintah diatas diulang untuk alamat IP lain dengan penyesuaian.

Lingkungan Praktik Jaringan Mikrotik dengan 2 Komputer

perangkat virtualisasi seperti virtualbox atau vmware sangat membantu dalam banyak hal. mari kita bermain-main sedikit.

jadi kondisinya begini.
– saya tidak punya routerboard
– saya hanya punya 2 komputer yang tidak kuat menjalankan vmware/virtualbox banyak2. sebuah PC-mac gadungan dan netbook berisi archlinux. asumsinya, setiap komputer hanya kuat menjalankan 1 OS virtual.

topologi yang ingin saya terapkan hanya routing sederhana dari 2 lingkungan berbeda, yang berarti membutuhkan minimal 3 komputer. 1 sebagai router, 1 sebagai komputer kelompok IP x, 1 lagi sebagai komputer kelompok IP y. sebenarnya, jika dipaksakan, komputer saya masih bisa dipasang 3 OS virtual dan jalan simultan. tapi sangat berat memang, lagi pula mempraktikkan sambil bermain bayang2 (karena perangkat mikrotik tidak benar-benar ada) lumayan bikin pusing. tentu saja tidak sulit mengubah PC biasa menjadi router, tapi yang saya maksud di sini, mikrotiknya virtual, tetapi port-port UTP-nya nyata, bisa kita sentuh dan OS host berikut data tidak terganggu.

mengapa tidak menginstall mikrotik secara native?
– karena ini komputer pribadi untuk keperluan sehari-hari, sebuah netbook dengan 1 port UTP dan 3 port USB.
– jika install native, hanya ada 1 port UTP, sementara USB2UTP tidak dikenal di mikrotik

dalam kasus ini, saya ingin punya sebuah ‘routerboard’ dengan 4 port, itu setara RB750 dengan performa yang lebih baik, menggunakan routerOS 5.xx trial 24 jam. sebenarnya, untuk belajar, versi routerOS ini tidak terlalu merepotkan dengan limit waktunya. bisa diakali dengan backup konfigurasi. sesering mungkin backup sistem dan unduh berkasnya. jika lewat batas waktu hanya perlu 3 langkah kecil. install ulang > konfigurasi IP salah satu interface > upload dan restore berkas backup. dan semua kembali seperti sebelumnya.

yang dibutuhkan untuk routerboard rakitan ini selain komputer adalah 2 atau 3 buah USB2UTP, jumlah tergantung kebutuhan.

pastikan semua USB2UTP bekerja dan semua interface di-up, tetapi tutup semua koneksi. saya menggunakan arch linux, dan networkmanager bawaan gnome tidak bekerja normal dengan mode bridge di virtualbox. matikan daemon networkmanager dan gunakan netcfg. buat 4 berkas di /etc/network.d/, salah satunya misal bernama bridge0 yang isinya :

INTERFACE="br0"
 CONNECTION="bridge"
 DESCRIPTION="Virtualbox Bridge"
 PRE_UP="ip link set dev eth0 promisc on"
 BRIDGE_INTERFACES="eth0"
 IP="no"

untuk berkas selanjutnya, ikuti penomoran, berkas bridge1 untuk eth1, bridge2 untuk eth2. kemudian aktifkan semuanya.

sudo netcfg bridge0

dan seterusnya. ini bertujuan menjembatani interface virtual langsung ke perangkat kerasnya.

buka virtualbox dan pilih mode bridge untuk jaringannya. Adapter network 1 dengan bridge0 dan seterusnya. setelah routerOS terpasang, kita akan mendapati semua interface mikrotik siap.

/interface print

yep, mikrotik siap digunakan dan anda bisa memperlakukan setiap port sebagai ‘routerboard’ sudah ada, bagaimana dengan lingkungan jaringan untuk routing? anda butuh 1 komputer lagi dengan 2 port UTP plus kabel2 UTP yang pendek dan menerapkan konsep yang sama. komputer host sebagai komputer kelompok IP x menggunakan eth0, sedangkan komputer guest (bridge ke eth1) sebagai komputer kelompok IP y. host dan guest tidak berhubungan langsung, melainkan melalu port mikrotik. tinggal diatur routingnya.

yup, hanya dengan 2 komputer, kita punya mikrotik setengah nyata dan lingkungan jaringan kecil untuk praktek. :)

easyhotspot dengan virtualbox : solusi murah dan tepat untuk billing hotspot

halo kawan.

kemarin saya lompat dari kursi saking senangnya mendapati easyhotspot bekerja dengan baik. apa itu easyhotspot? easyhotspot adalah sistem billing yang dibuat untuk keperluan hotspotan (itu lho, yang kalau mau ngenet hotspotan harus login dulu di browser, baru bisa ngenet). sebelumnya, ditawarkan untuk menggunakan mikrotik (sebuah OS router berbasis linux), sayangnya, harga jasa dan lisensinya sangat mahal. saat itu ditawarkan 1.6 juta. blah, ada cara untuk menghemat.

setelah googling untuk cari alternatif, saya temukan easyhotspot. silakan kemari. easyhotspot ini adalah paduan dari chillispot (captive portal), radius, apache, mysql dan lainnya, anda bisa menginstallnya di sistem operasi linux, dan bisa juga menginstall dengan distro linux easyhotspot (dari ubuntu) yang sudah siap pakai. saya menggunakan distro easyhotspot siap pakai.

nah, kendalanya, rasanya sayang sekali menambah satu komputer untuk dijadikan server billing hotspot ini, maka saya mencobanya secara virtual di atas PC bersistem operasi Windos. pertama saya coba dengan vmware tapi gagal, dan kedua dengan virtualbox, dan masih gagal. :P

tapi ujung-ujungnya berhasil kok. :)

kondisi

berikut kondisi saya :

  • sebuah komputer server bililing warnet biasa pake windos, prosesor dan ram mencukupi untuk menjalankan OS virtual dengan vmware maupun virtualbox.
  • sebuah modem (koneksi speedy) dan access point yang jadi satu (bawaan paket speedy, tp-link w8101g). bisa juga dengan modem dan AP terpisah.

jadi, tutorial ini mengikuti kondisi di atas, yaitu untuk modem ASDL.

install dan konfigurasi

install eashotspot di virtualbox (instalasinya sama persis seperti instalasi ubuntu, silakan merujuk ke tutorial instalasi ubuntu), tambahkan dua kartu jaringan.

  • NIC 1 = nantinya di ubuntu menjadi eth0, pada virtualbox, atur sebagai NAT.
  • NIC 2 – nantinya di ubuntu menjadi eth1, pada virtualbox, atur sebagai bridged.

nah, jika anda memperhatikan, saat virtualbox di install, ada network tambahan di windows anda, yaitu virtualbox-host-only (control panel > network). klik kanan> properties. ganti IP addressnya menjadi IP yang sah di jaringan nyata anda, dan jangan lupa gateway-nya juga (IP modem).

kembali ke ubuntu (asumsi sudah terinstall). klik network manager > edit connection. pilih eth1, dan atur IP-nya agar sama persis dengan virtualbox-host-only. eth0-nya biarkan pakai DHCP. restart network.

sekarang, aturlah agar DHCP di Access Pointnya dimatikan. kenapa dimatikan? awalnya saya juga bertanya-tanya. ternyata, pengurusan dhcp dialihkan ke kartu jaringan virtua kedua (eth1), nanti si ubuntu yang ngasih IP buat yang minta konek.

testing

anda bisa testing langsung pakai laptop, atau jika tidak ada laptop, pakai komputer biasa juga bisa (atur IPnya otomatis). kalau sudah konek, buka command line dan ketikan “ipconfig”, tanpa tanda ketik. jika di samping DNS suffix ada tulisan key.chillispot.info, berarti memang sudah benar. secara default, IPnya akan mengikuti 192.168.182.x.

bukalah browser dan masuk ke google.com. halaman akan dialihkan ke sebuah halaman login warna putih, akan ada tulisan easyhotspot login (anda bisa mengubah tampilan login ini sesuai selera anda). jika sampai di sini, selamat. :)

easyhotspot – dead simple opensource hotspot management system

sekarang, mari bermain sebentar dengan ubuntu virtual. jalankan browser, buka http://localhost/easyhotspot. akan muncul halaman login. masukkan user : admin, password : admin123. anda bisa menggantinya nanti.

setelah masuk, kita bisa mengkonfigurasi easyhotspot, antara lain pengaturan postpaid, paket hotspot, chillispot (sebaiknya pengaturan chillispot dibiarkan default), dan pengaturan user. tampilan antar mukanya cukup mudah untuk dimengerti, karenanya saya tidak menjelaskan dengan detail.

buatlah dan atur akun user biasa (nantinya sebagai operator). user dan password hotspot loginnya bisa di-generate dengan akun ini.

jika sudah dapatkan user dan password hotspot login, silakan dicoba. :D

tanpa skrinsut adalah hoax. :D

easyhotspot

easyhotspot

untuk informasi lebih lanjut mengenai easyhotspot silakan merujuk ke situs resminya.


This blog has been discontinued. All the contents, and new posts can be found at blog.pdft.net
Indonesia Linux Conference 2011

stats

SEO Stats powered by MyPagerank.Net
Counter Powered by  RedCounter

hits

  • 210,006 hits


This blog is licensed under a Creative Commons Attribution-Share Alike 3.0 Unported License.
pejuang mimpi tak ingkar janji

Ikuti

Get every new post delivered to your Inbox.