Arsip untuk Januari, 2012

Squid Proxy + Mikrotik

I have installed a cache proxy to centos server and works with good TCP_HIT. i’m using centos 5.x. proxy took the data that we request from browsing activities and save it as cache. the second request will take from this cache, that means the connection uses full bandwith on the local network. we got two thing, reduce bandwith consumtion from the ISP and increase the speed. squid has other feature such as redirect, blocking, etc.

on this case, the proxy’s IP set to 192.168.168.12, the same level to client computers.

install squid package from repository.

yum -y install

edit /etc/squid/squid.conf

change/add some.

#change the proxy port to 3128 and set as transparent. The transparent parameter means, this proxy can be used over the IP with port redirect.
 http_port 3128 transparent
 #add the hostname
 visible_hostname proxyserver
 #the TCP_HIT quantities depends on the refresh pattern parameter.
 refresh_pattern ^ftp:        1440    20%    10080
 refresh_pattern ^gopher:        1440    0%    1440
 refresh_pattern ^http:        720    90%    432000
 refresh_pattern -i (/cgi-bin/|\?) 0    0%    0
 refresh_pattern (Release|Package(.gz)*)$    0    20%    2880
 refresh_pattern -i \.(gif|png|jpg|jpeg|ico)$ 10080 90% 43200 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(iso|avi|wav|mp3|mp4|mpeg|mpg|swf|flv|x-flv)$ 43200 90% 432000 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(deb|rpm|exe|ram|bin|pdf|ppt|doc|tiff)$ 10080 90% 43200 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(zip|gz|arj|lha|lzh|tar|tgz|cab|rar)$ 10080 95% 43200 override-expire ignore-no-cache ignore-private
 refresh_pattern -i \.(html|htm|css|js|php|asp|aspx|cgi) 1440 40% 40320
 refresh_pattern .        0    20%    4320

save the file. then, create a swap directory

/usr/sbin/squid -z #swap

Check squid configuration. If there is an output, something wrong with squid.config, otherwise, all’s ok.

/usr/sbin/squid -k parse

start squid service

/etc/rc.d/init.d/squid start

use chkconfig to set squid to load on boot.

/sbin/chkconfig squid on

now, configure browser’s proxy to IP port 3128. open some static webpages and check log file.

tail /var/log/squid/access.log

if success, the webpage will loaded and squid will generate TCP_MISS to the logfile. we need to check again. give attention to logfile. clear the browser cache or use other computer to load the same pages. if TCP_HIT appears on the log, then your squid server is working fine. TCP_MISS means the data is not exist on cache and proxy server will load it from the internet. You will get TCP_HIT when data is exists and client load it from cache. the more you get TCP_IP, the more browsing speed increased for lots of data.

this is not yet complete. we need to enable the proxy server on router and setup it to redirect to 192.168.168.12:3128 using parent-proxy parameter.

set enabled=yes src-address=0.0.0.0 port=3328 parent-proxy=192.168.168.12 parent-proxy-port=3128

then, add a nat rule to force all request to router’s proxy (port 3328). strike the command bellow.

chain=dstnat action=redirect to-ports=3328 protocol=tcp src-address=!192.168.168.12 dst-port=80

voila. 🙂

NB : ini tulisan pertama dengan bahasa inggris. saya harap banyak yang salah dan seseorang memberitahu sehingga saya bisa belajar dari itu.

New Post WordPress

coba klik new post dari bar di atas (jika sudah login wordpress). dapatkan ini :

atau pergi ke http://wordpress.com/#!/post/

keren dan ringan. sayangnya saat saya coba, tombol upload foto tidak bekerja.

Dasar Mikrotik Plus Manajemen Bandwith

ditulis sebagai catatan pengingat. asumsi, menggunakan modem speedy (192.168.1.1) dan jaringan lokal 192.168.10.xx. salah satu client yang diatur bandwithnya adalah 192.168.10.2

1. Menambahkan password

$/password
 old password:
 new password:*****
 retype password:******

2. Memberi nama pada interface

/interface set 0 name=speedy
 /interface set 1 name=local

3. Memberi nama hostname

/system identity set name=routermikrotik

4. Set IP Address

/ip address add interface=speedy address 192.168.1.2 netmask 255.255.255.0
 /ip address add interface=local address 192.168.10.1 netmask 255.255.255.0

5.Set Gateway

/ip route add gateway=192.168.1.1

6. Set NAT

/ip firewall nat add chain=srcnat action=masquerade out-interface=speedy

7. DNS server

/ip dns set primary-dns=8.8.8.8 allow-remoterequests=yes

8. Manajemen Bandwith

/ip firewall mangle add chain=prerouting src-address=192.168.10.2 dst-address=0.0.0.0/0 action=mark-connection new-connection-mark=client01-con passthrough=yes
 /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=client01 passthrough=yes connection-mark=client01-con
 /queue tree add name=client01-up parent=speedy packet-mark=client01 limit-at=64k max-limit=512k
 /queue tree add name=client01-down parent=local packet-mark=client01 limit-at=64k max-limit=512k

4 perintah diatas diulang untuk alamat IP lain dengan penyesuaian.

Lingkungan Praktik Jaringan Mikrotik dengan 2 Komputer

perangkat virtualisasi seperti virtualbox atau vmware sangat membantu dalam banyak hal. mari kita bermain-main sedikit.

jadi kondisinya begini.
– saya tidak punya routerboard
– saya hanya punya 2 komputer yang tidak kuat menjalankan vmware/virtualbox banyak2. sebuah PC-mac gadungan dan netbook berisi archlinux. asumsinya, setiap komputer hanya kuat menjalankan 1 OS virtual.

topologi yang ingin saya terapkan hanya routing sederhana dari 2 lingkungan berbeda, yang berarti membutuhkan minimal 3 komputer. 1 sebagai router, 1 sebagai komputer kelompok IP x, 1 lagi sebagai komputer kelompok IP y. sebenarnya, jika dipaksakan, komputer saya masih bisa dipasang 3 OS virtual dan jalan simultan. tapi sangat berat memang, lagi pula mempraktikkan sambil bermain bayang2 (karena perangkat mikrotik tidak benar-benar ada) lumayan bikin pusing. tentu saja tidak sulit mengubah PC biasa menjadi router, tapi yang saya maksud di sini, mikrotiknya virtual, tetapi port-port UTP-nya nyata, bisa kita sentuh dan OS host berikut data tidak terganggu.

mengapa tidak menginstall mikrotik secara native?
– karena ini komputer pribadi untuk keperluan sehari-hari, sebuah netbook dengan 1 port UTP dan 3 port USB.
– jika install native, hanya ada 1 port UTP, sementara USB2UTP tidak dikenal di mikrotik

dalam kasus ini, saya ingin punya sebuah ‘routerboard’ dengan 4 port, itu setara RB750 dengan performa yang lebih baik, menggunakan routerOS 5.xx trial 24 jam. sebenarnya, untuk belajar, versi routerOS ini tidak terlalu merepotkan dengan limit waktunya. bisa diakali dengan backup konfigurasi. sesering mungkin backup sistem dan unduh berkasnya. jika lewat batas waktu hanya perlu 3 langkah kecil. install ulang > konfigurasi IP salah satu interface > upload dan restore berkas backup. dan semua kembali seperti sebelumnya.

yang dibutuhkan untuk routerboard rakitan ini selain komputer adalah 2 atau 3 buah USB2UTP, jumlah tergantung kebutuhan.

pastikan semua USB2UTP bekerja dan semua interface di-up, tetapi tutup semua koneksi. saya menggunakan arch linux, dan networkmanager bawaan gnome tidak bekerja normal dengan mode bridge di virtualbox. matikan daemon networkmanager dan gunakan netcfg. buat 4 berkas di /etc/network.d/, salah satunya misal bernama bridge0 yang isinya :

INTERFACE="br0"
 CONNECTION="bridge"
 DESCRIPTION="Virtualbox Bridge"
 PRE_UP="ip link set dev eth0 promisc on"
 BRIDGE_INTERFACES="eth0"
 IP="no"

untuk berkas selanjutnya, ikuti penomoran, berkas bridge1 untuk eth1, bridge2 untuk eth2. kemudian aktifkan semuanya.

sudo netcfg bridge0

dan seterusnya. ini bertujuan menjembatani interface virtual langsung ke perangkat kerasnya.

buka virtualbox dan pilih mode bridge untuk jaringannya. Adapter network 1 dengan bridge0 dan seterusnya. setelah routerOS terpasang, kita akan mendapati semua interface mikrotik siap.

/interface print

yep, mikrotik siap digunakan dan anda bisa memperlakukan setiap port sebagai ‘routerboard’ sudah ada, bagaimana dengan lingkungan jaringan untuk routing? anda butuh 1 komputer lagi dengan 2 port UTP plus kabel2 UTP yang pendek dan menerapkan konsep yang sama. komputer host sebagai komputer kelompok IP x menggunakan eth0, sedangkan komputer guest (bridge ke eth1) sebagai komputer kelompok IP y. host dan guest tidak berhubungan langsung, melainkan melalu port mikrotik. tinggal diatur routingnya.

yup, hanya dengan 2 komputer, kita punya mikrotik setengah nyata dan lingkungan jaringan kecil untuk praktek. 🙂

Colemak

Siilakan kunjungi :  http://colemak.com

Dulu saya keras kepala, masih bertahan dengan cara mengetik lompat-lompat, tanpa menggunakan kelingking dan jempol, dan meraih sekitar 40 kata per menit. Setelah chatting langsung dengan seorang kenalan dan menyaksikan secara realtime kecepatan mengetiknya mencapai 120 WPM (dulu ada apps di facebook untuk balapan mengetik dengan ilustrasi mobil balap) dalam bahasa Inggris, saya mulai belajar mengetik 10 jari. Saya sering menganggap masalah ketik-mengetik ini sebagai sebuah permainan, mencoba menantang diri sendiri. Saya suka gtypist, yang banyak membantu saya meningkatkan kecepatan mengetik dan juga apps2 untuk menantang seseorang di internet dalam adu cepat. Mungkin kebawa2 kebiasaan bermain rubik’s cube. 🙂

Sampai akhirnya saya  mencapai rata 90 WPM saat menulis sebuah lirik lagu atau kata-kata yang saya hafal di luar kepala. Ini membantu saya di banyak hal, terutama pekerjaan. Tetapi kadang-kadang tangan terasa sakit, ruas di pergelangan tangan kiri, di belakang jari tengah, manis dan kelingking. Saya sempat berniat mengganti ke layout keyboard lain, dvorak, tetapi menundanya setelah percobaan pertama yang sangat sukar. Lagi pula, ketika saya mencopot tombol-tombol dari papan ketik di komputer jinjing saya, saya menemukan bahwa tombol karakter ‘Z’ berbeda ukuran dengan tombol ‘?’, padahal di skema keyboard dvorak, posisi ‘Z’ ada di ‘?’. Mengecewakan memang.

Lama kemudian, di salah satu kopdar kaipang, saya kagum sama Pak Ajoeh, yang bisa menggunakan 2 layout keyboard, qwerty dan colemak, dengan kecepatan stabil. Malam itu juga saya langsung congkel semua tombol papan ketik dan menggantinya ke layout colemak. Seperti percobaan pertama di dvorak, colemak juga sangat sukar. Pak ajoeh bisa beradaptasi dengan cepat, semingguan katanya. Maka saya seharusnya juga bisa.

Dua minggu ini saya menggunakan keyboard Colemak, yang diklaim lebih ergonomis ketimbang qwerty. Di banyak review, dvorak masih lebih baik dari colemak, tetapi satu-satunya alasan yang saya pikir colemak lebih mudah karena membiarkan tombol zxcv yang mana benar-benar berguna untuk pekerjaan cepat.

Bagaimana proses adaptasi?

Saya mencoba mengingat-ingat ketika pertama kali mengetik, yaitu saya melihat keyboard. Saya menggunakan gtypist untuk pembelajaran tanpa lihat keyboard, dan setiap harinya masih mengetik dengan cara melihat papan ketik. Sangat menyiksa memang, tetapi saya yakin ini hanya masalah waktu.

Tombol yang paling sulit adalah S dan R. S hanya dipindah satu tombol ke kanan dan R menggantikan posisinya. Setiap mengetik S, selalu tertekan R.  Sementara tombol lain tidak begitu sulit. Ketika sedang menggunakan colemak tiba-tiba menggunakan komputer lain yang qwerty, adaptasinya cukup sulit, begitu juga sebaliknya ketika balik ke colemak.

Semoga saya bisa konsisten.

Oya, migrasi ke colemak ini membawa beberapa perubahan besar, salah satunya, orang yang biasa pinjam laptop makin sungkan minjam setelah sempat bingung dengan skema papan ketik yang baru. 😛

jam kerja main facebook?

sedikit proyek kecil. kalau coba2 buka facebook di kantor –>

sebuah server diaktifkan untuk http sekaligus DNS server (BIND) dengan domain facebook.com dan di mikrotik dibuat script terjadwal untuk mengganti DNS tersebut. 😛

update : kecuali bagian script terjadwal di mikrotik yang mengatur pergantian DNS, cara ini cocok untuk blokir permanen. penggantian DNS di mikrotik tidak langsung berpengaruh ke komputer klien. browser masih menyimpan dan menggunakan cache lama.

I AM [SHER]LOCKED

padahal dirilis tahun 2010, BBC series, tapi saya baru tahu sekarang. thanks mimi atas linknya.

Sherlock adalah film seri detektif yang berbasis tulisan Sir Arthur Conan Doyle namun mengambil latar setting modern. saya tidak keberatan dengan ini ketimbang apa yang ada di film layar lebarnya.

Film seri ini dikerjakan cukup keren dan serius. tokoh yang memerankan sherlock lebih jangkung watson, sesuai dengan deskripsi di buku. meski latarnya abad 21, detil2 kasus tetap dibawa dalam film2 ini. beberapa hal yang digantikan tetapi tetap pada konsep yang masa. misal di bukunya, saat Sherlock Holmes mencuri foto dari Irene, Watson membantu dengan teriakan kebakaran, tetapi di film seri ini, Watson membakar kertas majalah sehingga alarm otomatis milik hotel berbunyi. Berbeda tetapi sama. Pemeran Holmes (Benedict Cumberbatch) berakting sangat apik, tingkah lakunya benar-benar sesuai dengan yang di buku, meski pun saya agak ragu rambut Holmes yang sebenarnya sekeriting itu.

jika anda penggemar buku-buku Arthur, anda boleh kecewa dengan versi layar lebarnya, tetapi dijamin tidak dengan yang ini.


This blog has been discontinued. All the contents, and new posts can be found at blog.pdft.net

RSS latest post @ blog.pdft.net

  • Sebuah galat telah terjadi; umpan tersebut kemungkinan sedang anjlok. Coba lagi nanti.
Indonesia Linux Conference 2011

stats

SEO Stats powered by MyPagerank.Net
Counter Powered by  RedCounter

hits

  • 348,304 hits


This blog is licensed under a Creative Commons Attribution-Share Alike 3.0 Unported License.
pejuang mimpi tak ingkar janji